Home > firefox, ubuntu > Java plugin for Firefox under 64-bit Ubuntu 11.10

Java plugin for Firefox under 64-bit Ubuntu 11.10

This entry is based on this post.

Problem
I have a 64-bit Ubuntu (11.10) and I want Java support in Firefox.

Solution
My Java SE 7 update 2 is installed to /opt/java.

cd /usr/lib/mozilla/plugins  
sudo ln -s /opt/java/jre/lib/amd64/libnpjp2.so  

Trouble
Well, this isn’t working perfectly for me. In Firefox it appears under the Plugins tab and according to Java Tester it’s OK. However, if I visit http://java.com/en/download/help/testvm.xml, Firefox freezes :(

Categories: firefox, ubuntu Tags: , ,
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: